Very Poor Performance in Workspace

I’m having various issues:

  1. I’ll move cards around and create canvases and then all of a sudden bluescape (using Chrome) doesn’t respond to any of my mouse clicks or drags. I’ll refresh and after about 30 seconds it reloads but none of my prior changes were saved. It reverted back to a prior state. I’ve lost 20 minute chunks of work.

  2. I’m unable to move canvases consistently. I’ll click on a canvas to activate it and then long click to drag, but it won’t move. Only my mouse moves. When it does move, which is about 20% of the time, it is very jumping. In other words, I move my mouse and there’s about a 1 to 2 second delay before anything happens and then it moves in stages.

  3. I’ve had issues renaming the canvas. I type in an new name and when I mouse off of hit enter, it returns to the default Canvas7 in this example. However, when I double click the name, it will show the new name I gave it. Then when I mouse off, it reverts back to Canvas 7.

  4. When panning around in the workspace, it has about a 1 to 2 second delay. When it does move it moves in stages or chunks. So it moves a little at first and then it moves a little more and so on.

  5. The workspace will lock up at times. It won’t respond to anything I do. When I try to refresh it goes to a black screen and won’t come out of it.

  6. Some canvas titles are always visible even though “Always show title” is off. Some of the canvases showing this are “Lack of Distributed Engagement Across Members”, “Busy Lifestyle”, & “promote our progressive agenda to provide a home to…”

I’ve tested my network speed and it runs about 350M down and 53M up.

I’ve also tried incognito mode and have the same issues. Running windows 10.

Thank you for the details of the issues you are experiencing. We would like to aid to resolve the issues you are having.

To start we would like to get a few more details to aid in our investigation.

  1. What zoom level are you at in the workspace? If you use the default zoom level of 25% do you have the same experience?
  2. Can you verify the browser is up-to-date?
    a. Click on the Menu icon in the upper right corner of the screen. (three little dots)
    b. Click on Help, and then About.
    c. Verify the browser is fully updated & running the latest version.
  3. Clear the Web browser cache from the beginning of time.
    a. Click the menu (three dots in the upper-right corner).
    b. Select History.
    c. Select Clear Browsing Data from the left-hand side. Set the Time Range set to All Time. Check-mark Cookies and other site data and Cached images and files and select Clear Data.
    d. If on a Windows computer, close and re-open Chrome to save your changes. If on an Apple computer, go to the Chrome menu on the top menu bar and select Quit for the changes to take effect.
  4. Verify your system’s operating system is fully updated (i.e., Windows or Mac).
  5. Do you have any Web browser extensions enabled? If so, do you notice a difference when disabling them?
    a. Click the menu (three dots in the upper-right corner).
    b. Click More Tools > Extensions
  6. Try a different browser such as Firefox.
  7. When the browser freezes are the system resources running normally or are any spiked above average?

Please let us know if you have any questions on the steps provided. We are happy to assist.
If the above steps do not resolve the issue, we will want to collect the browser console logs and move the troubleshooting to a support case.

  1. I’m working at around 9% zoom. Still having the issues at 25% zoom.
  2. The chrome browser says it is up to date.
  3. I was running in incognito mode so none of the extensions were running.
  4. Windows is up to date.
  5. I tried running this in Edge as well as the Bluescape client and they both have the same issues. The bluescape client seems to run slower.
  6. I’ve just cleared my cache and am going to shut the browser down and re-test.

Before I responded to this post, I lost 30 minutes of work. The browser refreshed on its own - it gave me a lost connection error to bluescape and when the home screen came back it said that my workspace was lasted updated 30 minutes ago.

Clearing the cache did not work.

Also, when I closed down the browser, I was able to open my bluescape workspace without a problem. However, when I hit the Bluescape Community link under the “?” menu in the bluescape, a new window opened up but the page was black and the tab was showing it was trying to connect. I let it go for 2 minutes and it still didn’t connect. I tried it 3 times before the community page came up. When it came up it filled in quickly. At the same time I had the connection issue to the community page, I pinged bluescape.com and it came back with 16ms avg. time. Not sure if this is related to the issues in the workspace.

I just tested out the performance through my work account and I’m not having any of the same issues. Using the same computer and browser.

Are you on your company’s VPN? If so, can you try to disconnect from it and try.

I am not on my companies VPN. Nor was I when I tested out my companies workspace. I figured if the issue was on my end then I should have the same issue no matter the workspace instance. Since all worked well for my companies workspace, my thought is that my personal workspace has an issue or the servier it’s on.

The undo function is erratic. I can make a couple of changes such as moving text boxes around, but the undo button stays grayed out as if it’s not acknowledging that I just made a change. This usually then leads to me losing work when the workspace refreshes because the changes I made revert back to the prior state.

I will open up a support case and follow up with you by email directly.

Hey @tzbarash! We’re glad @Kat_G was able to kick-start a support ticket for you and it looks like @cody.bentley from our support team was able to help you out!

He shared that your workspace performance could in part be impacted by a large number of canvases and notecards layered around same area of your workspace.

For you and other members who may be experiencing similar workspace performance issues, we suggest the following:

  • Delete old content that is not necessary.
  • Zoom in when navigating around.
  • Space content out.
  • Use different navigation functionalities (i.e., search feature).
  • Limit how often you close the tab of the workspace.
  • Minimize other programs running on your computer.
  • Make sure your internet connection is stable.
  • Create multiple workspaces as you progress through a project.

Hope this helped!

2 Likes