"Screenshare not available. Permission denied" error message when sharing screen in web

Support Note
The below topic outlines a known issue that members may encounter with Mac OS / Chrome. Bluescape is aware of this issue.

Steps to reproduce

  1. I log in to My Bluescape on the web.
  2. From the Home page, I click on “Start new meeting.”
  3. I click on the “Join call” button from the meeting lobby.
  4. I click on the “Share screen” icon inside the call.
  5. I begin sharing my screen.

Expected result

The “Share your screen” dialog opens. The meeting continues to run.

Observed result

“Screenshare not available. Permission denied” error toast message is displayed when clicking on the “Share your screen” icon. However, the meeting keeps running.

Where to Next?

Not what you were looking for? Reply below or Search the community and discover more Bluescape.

How to fix this issue:

If you are a Mac OS / Chrome user, screen recording is not appropriately supported unless your Privacy preferences for Google Chrome are unlocked.

To change your Privacy preferences for screen recording on your Mac, select Apple menu > System Preferences > Security & Privacy > Privacy > Screen Recording.

If your lock icon in the bottom left of the Privacy pane is locked, click on it to unlock your preference pane. Select Google Chrome to allow the app to record the contents of your screen.

Note: If Google Chrome is already selected, toggle the box off/on again and rerun the application.

Learn more about how to change Privacy preferences on Mac:

2 Likes

Hi Lauren and team. I have my privacy settings set properly but am still encountering this issue.

If you are still experiencing this issue with Chrome browser, please don’t forget to uncheck and check the box again. You will be presented with this dialog.

Select “Quit & Reopen” to apply the change.

Hi - that fixed it. I had to untoggle/retoggle. Much appreciated @Borce_Lozanovski and @michellefs for the followup!

2 Likes